rsvr.net Forums Homepage
Forum Home Forum Home > RSV / RSVR / FACTORY > Technical Chat
  New Posts New Posts RSS Feed - Fuel Issues - Gen2
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Fuel Issues - Gen2

 Post Reply Post Reply
Author
Message
Johnny Mac View Drop Down
Moto3 racer
Moto3 racer


Joined: 11 Feb 2008
Status: Offline
Points: 55
Post Options Post Options   Thanks (0) Thanks(0)   Quote Johnny Mac Quote  Post ReplyReply Direct Link To This Post Topic: Fuel Issues - Gen2
    Posted: 13 Mar 2016 at 15:15
Hi Lads,

Posted here last week regarding an issue I had where the fuel light wasn't coming on. Filled her up and went out today, the issues go on.

After the full tank was drained of about 20 miles worth of fuel the bike started missing when on full gas.

The more the fuel went down the worse it got and the lower down the rev range the issue came.

Eventually the red triangle would appear on the dash after a few misfires and the only resolution was to turn off at the key and back on again - that would get me another few miles

Out of frustration I stopped in for fuel and got just 8 litres into it, low and behold the issue went away. 

Last 10 miles home it didn't miss a beat.

Any ideas? Fuel pump or filter issue?

The tank has been off for painting, was bone dry for a few weeks.

Replaced plugs too last week, to rule that out.

2004 Gen2

Thanks 
Keep 'er lit!!
Back to Top
IanG View Drop Down
Premium Member
Premium Member
Avatar

Joined: 04 Oct 2010
Location: N Wales
Status: Offline
Points: 8410
Post Options Post Options   Thanks (0) Thanks(0)   Quote IanG Quote  Post ReplyReply Direct Link To This Post Posted: 13 Mar 2016 at 16:08
Perforated internal lines?

Wasn't it the Gen2 that was prone to this?  Or was that the version that had the wires pulling out of the moulded plug on the tank?
www.apriliaperformance.co.uk
www.apriliaforum.co.uk
www.apriliaownersclub.co.uk

Looking forward to the next track day
Back to Top
Mikey View Drop Down
Moto3 racer
Moto3 racer


Joined: 05 Feb 2015
Location: Finland
Status: Offline
Points: 37
Post Options Post Options   Thanks (0) Thanks(0)   Quote Mikey Quote  Post ReplyReply Direct Link To This Post Posted: 13 Mar 2016 at 16:26
Bad fuel pump starts acting out when the fuel inside the tank warms up. If refilling the tank (which cools down the contents) helps for a moment, then the pump is to blame. 
RSV1000R, m.y. 2007
Back to Top
Johnny Mac View Drop Down
Moto3 racer
Moto3 racer


Joined: 11 Feb 2008
Status: Offline
Points: 55
Post Options Post Options   Thanks (0) Thanks(0)   Quote Johnny Mac Quote  Post ReplyReply Direct Link To This Post Posted: 13 Mar 2016 at 17:27
Originally posted by Mikey Mikey wrote:

Bad fuel pump starts acting out when the fuel inside the tank warms up. If refilling the tank (which cools down the contents) helps for a moment, then the pump is to blame. 

So pulled the tank off and extracted the fuel pump. Do you need a special tool to clamp/unclamp them hoses?

Keep 'er lit!!
Back to Top
Johnny Mac View Drop Down
Moto3 racer
Moto3 racer


Joined: 11 Feb 2008
Status: Offline
Points: 55
Post Options Post Options   Thanks (0) Thanks(0)   Quote Johnny Mac Quote  Post ReplyReply Direct Link To This Post Posted: 13 Mar 2016 at 17:43
And ordered one of these to be sure 

http://fuelperformance.co.uk/index.php?route=product/product&product_id=217
Keep 'er lit!!
Back to Top
redratbike View Drop Down
Moderator Group
Moderator Group
Avatar
The Collector Messiah

Joined: 07 May 2008
Status: Offline
Points: 14740
Post Options Post Options   Thanks (0) Thanks(0)   Quote redratbike Quote  Post ReplyReply Direct Link To This Post Posted: 13 Mar 2016 at 18:41
change the intank filter at the same time


www.apriliaperformance.co.uk
www.apriliaforum.co.uk
www.apriliaownersclub.co.uk
Back to Top
Johnny Mac View Drop Down
Moto3 racer
Moto3 racer


Joined: 11 Feb 2008
Status: Offline
Points: 55
Post Options Post Options   Thanks (0) Thanks(0)   Quote Johnny Mac Quote  Post ReplyReply Direct Link To This Post Posted: 14 Mar 2016 at 21:54
I see Halfrauds have an equivalent filter for quarter the price but it's metal. Any idea where the blue anti-static connection would go in that case??

It's a HFF232
Keep 'er lit!!
Back to Top
Johnny Mac View Drop Down
Moto3 racer
Moto3 racer


Joined: 11 Feb 2008
Status: Offline
Points: 55
Post Options Post Options   Thanks (0) Thanks(0)   Quote Johnny Mac Quote  Post ReplyReply Direct Link To This Post Posted: 20 Mar 2016 at 21:37
So.

All sorted, new fuel pump and filter and it pulls like a bastard at the top compared to before.

Fuel light is all sorted now too, didn't replace the sender so related to the pump somehow.
Keep 'er lit!!
Back to Top
Fugly View Drop Down
Moto GP Alien
Moto GP Alien
Avatar

Joined: 18 Nov 2015
Location: Cambridgeshire
Status: Offline
Points: 708
Post Options Post Options   Thanks (0) Thanks(0)   Quote Fugly Quote  Post ReplyReply Direct Link To This Post Posted: 21 Mar 2016 at 13:14
Glad you got it sorted Johnny, the replacement fuel pump looks like a good find.  Will keep that on file just in case
Full Arrows system, 1060 Big Bore, PC5 and Evo Airbox. Bring on the big grin!
Back to Top
martinh View Drop Down
Premium Member
Premium Member


Joined: 14 Sep 2015
Location: plymouth
Status: Offline
Points: 87
Post Options Post Options   Thanks (0) Thanks(0)   Quote martinh Quote  Post ReplyReply Direct Link To This Post Posted: 26 Mar 2016 at 12:59
Where did you get the filter from in the end? Looking at changing mine soon when I have the pump out next week.
Back to Top
Crownan View Drop Down
Premium Member
Premium Member
Avatar

Joined: 17 Mar 2014
Location: Chertsey
Status: Offline
Points: 436
Post Options Post Options   Thanks (0) Thanks(0)   Quote Crownan Quote  Post ReplyReply Direct Link To This Post Posted: 01 Apr 2016 at 14:11
What did you do about the clamps in the end?
2007 RSV-R
Back to Top
Johnny Mac View Drop Down
Moto3 racer
Moto3 racer


Joined: 11 Feb 2008
Status: Offline
Points: 55
Post Options Post Options   Thanks (0) Thanks(0)   Quote Johnny Mac Quote  Post ReplyReply Direct Link To This Post Posted: 06 Apr 2016 at 21:35
Originally posted by martinh martinh wrote:

Where did you get the filter from in the end? Looking at changing mine soon when I have the pump out next week.

I went for the Halfords one, HF232 and just used the clamps (jubilee clips that came with the fuel filter that I got.

Running no problems and hasn't exploded into a fireball yet Tongue
Keep 'er lit!!
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.00
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.047 seconds.